Oct 14, 2020
When loading the software onto a computer, the error 1327, Invalid Drive: X:\ is raised where X is a drive letter name from which the installation is being run.
Cause
This behavior may occur if a registry key contains an incorrect value in a Data field.
Resolution
Verify that registry entries do not contain invalid drive letters that might be causing this error.
- Click Start, and then click Run. The Run dialog box opens.
- In the Open field, type regedit, and then click OK. The Registry Editor opens.
- In the Registry Editor, locate the following registry key:
- HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Shell Folders
- In the right pane, note the values in the Data column of each entry. If any value contains a drive that is not correct for your computer, right-click the entry and select Modify.
- Type the correct drive letter in the Value data field, and then click OK. For example, if one of the values is "X:\Documents and Settings\Administrator", the drive letter should be changed to a valid drive on the system, such as “C:\Documents and Settings\Administrator".
- Repeat steps 4 and 5 for each entry whose Data value contains an incorrect drive.
- Repeat steps 3 through 6 for each of the following registry keys:
- HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders
- HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion
- HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\Shell Folders
- HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders
- Close the Registry Editor and run the installation again.